TINA-TI 应用常见问题解答

一般问题

  1. 什么是 TINA 和 TINA-TI?
  2. TINA-TI 版本 7 和 9 之间的主要差异是什么?
  3. 能否继续使用 TINA-TI 版本 7?
  4. 从何处可以获取 TINA-TI 版本 9?
  5. 从何处可以获取完整版 TINA 版本 9 或将 TINA-TI 版本 9 升级到 TINA 的完整版?
  6. 运行 TINA-TI 版本 9 的最低系统要求是什么?
  7. 从何处可以获取 TINA-TI 帮助?
  8. 如何检查工具更新?

模拟

  1. 从何处可以找到 TI 器件模型和应用电路?
  2. TINA-TI 能否运行导自其它模拟器的电路?
  3. 导自 TINA-TI 的电路能否在其它模拟器上运行?
  4. 如何执行参数分析?
  5. 如何控制模拟的精确度和速度?

波形显示

  1. 如果在运行模拟之前未使用电压表,能否探测节点电压?
  2. 如何更改模拟进程消息模式?
  3. TINA-TI 是否有波形测量工具?
  4. 如何计算环路增益?
  5. 如何测量显示窗口中的波形?

模型与电路开发

  1. 如何编辑 TINA 器件模型符号?
  2. 能否从 TINA-TI 创建 TINA 库?

什么是 TINA 和 TINA-TI?
TINA 是在 Microsoft Windows 操作系统中运行的基于 Spice 的电路模拟器。可执行电路 DC、AC、瞬态、傅立叶、噪声分析等。TINA 可通过供应商 (DesignSoft) 位于 www.tina.com 的网页购买。

TINA-TI 是 TINA 的简单版本,具有电路仿真的完整功能,但封装中的电路开发实用程序更少。而且,TINA-TI 包含更多的 TI 器件模型和 TI 器件信息。TI 通过 www.ti.com/analogelab 在全球免费发布 TINA-TI。

TINA-TI 和 TINA 设计套件版本比较

程序特性 TINA TINA-TI
原理图录入和编辑
撤消/重做
自动/手动有线路由和拖动支持
仪器作为标准原理图符号
子电路
BOM
总线
集成网络列表编辑器
任意波形的激励编辑器
原理图符号编辑器
组件工具栏编辑器
PCB 导出到主要封装
带版本控制的分层与团队设计
参数提取器/模型生成器
PCB 设计
分析
最大 外部节点数和宏中的节点数 无限制 无限制
DC、AC、瞬态、数字、混合模式仿真
组件和模型数 20,000 565 个 TI IC 模型和其它支持器件
组延迟
参数扫描
直接从网络列表分析
稳定状态解算器(SMPS 分析)
S 参数指定的射频模型
网络分析
射频、数字、VHDL、MCU 仿真
VHDL 外部调试器
交互模式
仿真运行过程中电路发生更改
符号分析(闭型公式)
傅立叶分析(谐波)
傅立叶分析(光谱)
蒙特卡洛,最坏的情况 将 MC 与噪声分开
压力(烟雾)分析
优化目标和参数数量 无限制
参数步进中的参数数量 无限制 1
输出功能
缩尺图
多轴
用于增强图的绘图工具
后处理工具
Smith、奈奎斯特、零极点图
内置 DTP 工具
MathCAD 和 Excel 导出
虚拟仪器
XY 录像机、示波器、函数发生器、万用表、信号分析器/波德绘图仪
网络、光谱和逻辑分析器
数字信号发生器
实时测试和测量
教育特性
返回页首


TINA-TI 版本 7 和 9 之间的主要差异是什么?
TINA-TI 版本 9 是版本 7 的重要升级。主要升级出现在以下领域:

返回页首

能否继续使用 TINA-TI 版本 7?
版本 7 将继续得到短时间的有限支持。建议用户下载最新版本的 TINA-TI 以获得版本 9 的所有优势。

TINA-TI 版本 7 上的电路将在版本 9 上工作。但是,保存在版本 9 中的电路不能在版本 7 中打开,除非在“文件保存”对话框中选择了“另存为 TINA v7 原理图的选项”,见如下所示。

返回页首

从何处可以获取 TINA-TI 版本 9?
TINA-TI 版本 9 由 TI 分发。可以从位于 www.ti.com/analogelab 的 TI 网站上免费下载。

返回页首

从何处可以获取完整版 TINA 版本 9 或将 TINA-TI 版本 9 升级到 TINA 的完整版?
完整版 TINA 可从 www.tina.com 网站上的 DesignSoft 购买。当前安装了 TINA-TI 版本 9 的用户在购买完整版时将享受折扣优惠。

:请在购买后 7 天内加载此程序,以防下载链接到期。

返回页首

运行 TINA-TI 版本 9 的最低系统要求是什么?
运行 TINA-TI 版本 9 的最低硬件和软件要求是:

返回页首

从何处可以获取 TINA-TI 帮助?
工具中有基本帮助信息,可从“帮助”菜单访问。

有关与 TINA-TI 有关问题的帮助,请转至供应商的网站 www.tina.com 或其支持论坛 DesignSoft 论坛

有关与 TI 器件模型有关的问题,请将您的问题发布在 TI E2E 社区模拟和模型论坛

返回页首

如何检查工具更新?
要检查更新,必须有 TINA-TI 版本 9 或更新版本。

从菜单中:

  1. 单击“帮助”
  2. 选择“检查更新”选项
  3. 如果有可用的更新,将出现一个屏幕,显示消息:“检测到新的组件”。当屏幕上出现此窗口时,单击“更新”按钮。

将出现下载站点。遵循说明完成更新。

返回页首

从何处可以找到 TI 器件模型和应用电路?
TI 器件模型和应用电路与 TINA-TI 一起发布。从安装目录的 directory(工具安装目录)\examples\ 中可以找到 TI 器件电路。目录中的电路按应用分类。例如,directory\examples\SMPS\ 包含 TI 开关模式电源应用电路。Directory\examples\TI test circuits\ 包含所有 TI 线性器件模型测试电路。

TI 器件模型在主窗口(器件栏)上部的“Spice 宏”标签中。请观看有关如何在电路中插入器件模型的视频。(:查看示例需要视频查看器。)

返回页首

TINA-TI 能否运行导自其它模拟器的电路?
能,TINA-TI 可以从其它 Spice 模拟器导入电路,但只能以 Spice 网络表电路形式导入。要运行 Spice 网络表电路,请从 TINA 菜单中打开 TINA-TI 网络表。选择“工具”,然后选择“网络表编辑器”。打开电路,运行电路分析。

返回页首

导自 TINA-TI 的电路能否在其它模拟器上运行?
能,TINA-TI 与 PSpice 兼容。在 TINA-TI 中创建的 Spice 网络表可以在 PSpice 中运行。

从工具的菜单中,依次选择“文件”、“导出”和“网络表...”。可创建 TINA-TI 电路的网络表文件,然后在 PSpice 中运行。

返回页首

如何执行参数分析?
步骤 1:在运行参数分析之前,添加所需的组件作为参数分析对象。从菜单中单击“分析”,然后单击“选择控制对象”。例如,用鼠标单击所选的组件 R2,然后查看此窗口:

单击“...”按钮,从下一个窗口填写参数值:

在窗口中填写字段之后,单击“确定”。所选的组件被设置为参数分析对象。

步骤 2:运行电路分析仿真。您将看到电路性能根据所选的参数对象值发生变化。请观看有关如何执行参数分析的视频。:查看示例需要视频查看器。)

步骤 3:在运行参数分析之后,通过调用“参数步进”窗口并单击“删除”按钮,可以删除作为参数对象的组件

返回页首

如何控制模拟的精确度和速度?
有许多因素对仿真精确度和速度产生影响。通常,“陡沿”信号、高错误限制或低 GMIN 将降低仿真速度。需要在仿真精确度与速度之间进行取舍。通过调整程序中的仿真参数,可以控制仿真速度与精确度平衡。从主菜单中,单击“分析”,然后单击“设置分析参数...”。将显示此窗口:

作为常规要求,可使用此设置。对于以大约 100KHz 工作的电路,将“TR 最大时间步长”设置为 100ns。对于开关模式或数字电路,TR 最大值相对错误 [%]" 设置为大约 1.0%,以加速仿真。

减少“保存的 TR 点的最大数量 ”的值将降低波形显示分辨率,但不会影响仿真精确度。然而,模拟器将保存更少的数据,以便分析波形更快显示。

从上面窗口中单击手按钮,以保存设置,加载以前保存的设置,或查看完整的分析参数列表。

返回页首

如果在运行模拟之前未使用电压表,能否探测节点电压?
能,通过从“分析选项”窗口中选择“保存所有分析结果”。从菜单中,选择“分析”,然后选择“选项...”。请观看有关如何在仿真后探测信号的视频。:查看示例需要视频查看器。)

返回页首

如何更改模拟进程消息模式?
在仿真过程中,TINA-TI 将按百分比、消息或详细信息显示仿真进程状态。从菜单中单击“分析”,然后单击“选项...”,可以从“分析选项”窗口中选择一种模式。在“常规”标签中,从“跟踪模式”中进行选择。请观看有关如何选择仿真进程消息栏的视频。(:查看示例需要视频查看器。)

返回页首

TINA-TI 是否有波形测量工具?
是,TINA-TI 可以计算波形。单击波形图窗口顶部的“添加曲线”图标,打开“后处理”窗口。选择所需的功能类型和涉及的信号。请观看有关如何进行波形计算的视频。(:查看示例需要视频查看器。)

返回页首

如何计算环路增益?
有几种方法可以计算 TINA-TI 中的环路增益,而这里将介绍一种比较简单的方法。请观看有关如何计算环路增益的视频。(:查看示例需要视频查看器。)

步骤 1:从原理图窗口的主菜单中,将电压源输入到带有电压发生器的反馈环路中,然后将其属性设置为:

  “信号”=“正弦波”
  “IO 状态”=“无”


步骤 2:将两个电压引脚置于电压发生器接线端上 - 引脚 1 位于正端,引脚 2 位于负端。


将电压引脚属性设置为:

   引脚 1:“IO 状态”=“输出”
   引脚 2:“IO 状态”=“输入”


   。。。和 。。。

步骤 3:运行 AC 模拟。从电压发生器的正端到负端的环路增益将被计算出来,并且会显示波形显示窗口。

返回页首

如何测量显示窗口中的波形?
从波形显示窗口中,双击其中一个轴以激活“设置轴”窗口。


在窗口底部找到“对轴刻度取整”。此复选框控制信号刻度显示。

如果未选定该复选框,工具将按照在“设置轴”窗口中输入的上限、下限和刻度,使用以下公式计算刻度:

(“上限”-“下限”)
     “刻度”

如果已选定该复选框,工具会自动将刻度设定为取整数并忽略在“设置轴”窗口中输入的上限、下限和刻度。

例如,如果未选定“设置轴”窗口中的“对轴刻度取整”复选框,波形将按照在“设置轴”窗口中输入的值显示 7 刻度,其中上限 = 86,下限 = -82。


如果已选定“设置轴”窗口中的“对轴刻度取整”复选框,波形将显示为取整数并且忽略在“设置轴”窗口中输入的上限、下限和刻度。

返回页首

在 TINA-TI 中能否使用自己的器件模型?
如果您有 Spice 模型,则可以为此器件创建一个宏模型,并在 TINA-TI 中使用。请参阅问题“如何从网络表(文本格式)模型创建 TINA 宏模型?”。

返回页首

如何从网络表(文本格式)模型创建 TINA 宏模型?
TINA 的完整版可从原理图电路(*.TSM 文件)和网络表电路(*.CIR 文件)创建宏模型。TINA-TI 只能从网络表模型(*.CIR 文件)创建宏模型。

步骤 1:创建一个 Spice 格式的子电路网络表文件,并保存为“*.CIR”文件。下面是 Spice 子电路(用于 B340A 二极管)的示例:

subckt b340a 1 2

*... ...

*模型内容

*... ...
.ENDS

步骤 2:使用 TINA“工具”菜单中的“新建宏向导”创建一个宏模型。



将打开一个对话框:


在上面窗口中填充字段。在“宏名称”文本框中,输入宏模型的名称。在原理图中使用此模型时,该名称将出现在原理图上。输入或定位至宏的 CIR 文件。另外,您还可以选择“从网站”选项,然后使用直接在因特网(例如,从供应商的网站)上找到的文件。确定 .CIR 文件后,单击“下一步”进入下方显示的对话框:

选择“从库中载入形状”从 TINA 符号数据库(*.DDB 文件)(如果存在)中选择特定的符号。然后您可以滚动浏览所有现有符号,以查看是否某个符号适用于您的器件。您可以通过选中“仅显示推荐的形状”或选择“引脚数”和“形状类型”过滤所选项。或者,选择“自动生成形状”,对您的器件始终使用自动生成符号。找到理想的符号后,请单击“下一步”。您将马上看到此对话框:

在形状下方,您将看到位于未分配的宏模型网络表中的引脚。您还可以通过单击引脚数并将其拖至您希望关联该引脚数的符号上的引脚,将这些引脚与该符号相关联。以我们为例,我们按如下所示连接这些引脚。

单击“下一步”,您将看到一个文件对话框,可以按自己的意愿保存宏模型。

保存后,您将看到此对话框:

步骤 3:按最后一个对话框上的“插入”按钮,或随时从 TINA 菜单相继选择“插入”、“Macro...”。浏览之前保存的模型文件,将此宏模型放入电路。

返回页首

如何编辑器件模型符号?
将器件模型符号放在原理图上之后,用户即可对其进行编辑。当指针在器件符号上时,单击鼠标右键,选择编辑符号选项即可对其编辑。

修改只会影响模型的当前实例。不影响数据库中模型的新实例。

返回页首

能否从 TINA-TI 创建 TINA 库?
不能,此实用程序只在完整版 TINA 中才可用。

返回页首